Yamaha Powersport Forums banner
1 - 19 of 19 Posts

·
Registered
Joined
·
74 Posts
Post up some pics of that bad boy! My neighbor is a mechanic at the local bike shop (there's only one, imagine that ) and he said they're making some pretty trick aftermarket exhausts for the VStar now...
 

·
Lost in the Lake
Joined
·
193 Posts
Discussion Starter · #3 · (Edited)
I have installed the yamaha Performance exhaust. Dual pipes instead of the single big one, and straight back. Shotgun style. Friend with a harley is jealous of the sound it puts out. I will get more pics of it in the near future. Leaving on vacation tommorrow.

This pic is of the first 300 miles day trip on it. Went to Cave of the Mounds outside Madison, WI.
 

·
Registered
Joined
·
30 Posts
Nice bike.
Natural progression from the sportbike to the cruiser community. I like the sportbikes more, but I have always had a soft spot for a big twins soul.
 

·
Registered
Joined
·
21 Posts
Welcome aboard! Sounds like we are in the same boat. I jumped from a sport bike to a cruiser as well. I really needed something for longer rides and I'll admit that I really like the ability to customize these things into whatever it is that I want. Plus the fact that I'm getting a bit older - maybe a bit wiser - and I haven't skinned an elbow or had to do plastic repair since I got the Star. Here in Arizona it's hard to find good curvies that the cops aren't all over anyway... but there are tons of great riding roads and just about every day is a good day for a ride weather wise.

again....welcome aboard
 

·
Registered
Joined
·
1 Posts
do you have pics of new pipes on
how do you like the sound, did you install a fuel pac if so what brand was it.
i just purched a new 07 tour red, and would like to have pipes and still looking
thanks for any info.
 

·
Lost in the Lake
Joined
·
193 Posts
Discussion Starter · #7 ·
I dont have any pictures right now. I am actually trying to sell the bike. I didnt' install a fuel pack, as the computer has compensated for the new pipes. There are oxygen sensors in the new pipes as well, so the computer senses the extra airflow. Dealer recommended not installing one unless I wanted more performance.
 

·
Premium Member
Joined
·
4,776 Posts
I have a V star 1300 Tourer Black. I really like it. Had not had one for about 20 years. Having a blast with it. Ride it to work almost every day. Had to miss a couple of days due to rain.:scooter
Very nice... I bet it feels good to be back on two wheels after all that time. :)
 

·
Registered
Joined
·
2 Posts
I'am new to the forum, with a brand new V Star 1300 Touring bike, have 400 miles so far with lots more planned for the future. This is one great bike after many rides that I've had finially a keeper.Looking for lowers to go with the windshield.Channelrat
 

·
Registered
Joined
·
1 Posts
1998 VStar Classic Electrical Problems

Hey folks,

New here to the forum and a new rider as well. Just picked up a '98 650 Classic and was having a great time on it for about 2 weeks. Went out a few days ago to fire it up for my morning commute it laboured a bit to turn over but it did. Next morning, nothing at all. Brand new battery in it but still began with simple stuff; tried to boost it and nothing at all. With the ignition turned on I get lights full on bright, horn blast for 10 seconds with no discernable battery drain and signals work fine.

Some people have told me that I'm looking at a starter problem or a solenoid. I'm somewhat mechanically inclined, but not a wizard by any stretch.

Anything that anyone could give me a hand with would be much appreciated,

Thanks
 
1 - 19 of 19 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top