Yamaha Powersport Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #2 ·
Rides maybe 20 miles, then battery dead. 3 years with this problem, need fix.
Heard the voltage relay, or it's called something else on bikes, has a long standing failure problem. Bike shops wanted over $100, but amazon had EXACT same part for $20 and overnight delivered. Replaced that and seemed a lot better, but still over draining a touch with all lights on at night. I guy on FB Michigan bike group suggested trying LED headlight. It's a 9003 standard car size, I had put the brightest halogens in both lamps, but still not very bright and guess were over draining system. So, Amazon a LED and using only one lamp. OMG, it is perfect, so bright, like a normal headlight should be. I'm guessing because can't remember, but the halogen drain was 60 watts each bulb, the LED is 10 watt and 10 times brighter. The charging or stator can handle the load fine for now. Daylight getting short and be good rest of season.

One question, rear turn signal incandescent draining, lights dim with each flash. Switch led with those and solved the drain and brighter, but it's causing all 4 turn signals flash same time instead on or other. suggestion's?
 

·
Administrator "Loose Nut" - from Houston, Texas
Joined
·
106 Posts
The "cost effective" regulators are infamous to fail quickly. Just be prepared to replace soon. That OEM one that probably just went dead is over 30 years old, that's a pretty good electronic live. I would rest the stator for output to ensure you are replacing the correct failed part.
 
1 - 3 of 3 Posts
Top