Yamaha Powersport Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have owned this bike since day one and have added a vance & hines ss2r slip on, dyna jet stage 3 jet kit and a k&n stack to the motor. The bike ran great for 8 years with this set up and then I started having carb problems so I took it to the dealer for repair and they told me the jets were reversed in the carb ... how is this posible ? They said I needed to go back to the stock jets and they adjuster the exup valve and the bike ran like crap. I found a local guy that has a lot of knowledge about yamaha so we dicided to put a new stage 3 kit in the bike but we are unsure of where the exup valve needs to be with the mods on the bike. Does anyone know... I called yamaha direct and they had no answers for me. Main problem with the bike is low end and idle seems to me when over 3000 the valve does not come into play with respect to the proformance of the bike. Can anyone help ?
 

·
Registered
Joined
·
178 Posts
I know why the jets were reversed and its not the cause of your problem.

When i ordered a new dynojetkit for my bike and was going to install it it turned out the mount for the main jets were not the same. It seems some carbs have screwmount and some have a mounting with a small bracket, fastened to another jet right next to the main jet.
In order for the new jet to fit I had to turn it upside down and clamp it with the bracket, the same way the old jets were mounted. The jets are the same on both ends and the bike ran the same with the jets reversed as earlier. After this i got a new set of carbs off an FZR 1000, and these had the screw mount so the jets fit proper in those.

I also have low rpm and idle problems and have had so since I got the bike, seems lots of YZF's have them. The EXUP should really just be adjusted to standard setting. If you want more power, change the exhaust. But you'll lose low down grunt.

Possible cause for the low end problems are sticking valves.
 
1 - 2 of 2 Posts
Top