Yamaha Forum : Your Yamaha Motor Products Community & Resource - Reply to Topic
Thread: 2000 timberwolf yfb250fw middle drive seal Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Yamaha Forum : Your Yamaha Motor Products Community & Resource forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
12-15-2011 06:51 AM
tman It was definitely pressed in from the inside behind a pressed in bearing. I have completed the project and fixed the issue but there was definitely some poor design around that! By pulling the swing arm and then using a low profile box end wrench to get the u-joint nut off I was then blocked by the cross over frame rail. I cut out the rail removed the middle drive (repaired and re-installed it) then welded the frame rail back into place. This was by far easier than pulling the complete engine
12-09-2011 07:49 PM
itsmygame I've been around the block afew times and have never seen a seal mounted from the inside. It goes agaisnt there basic principle. To keep fluid in. Have someone that knows more to make sure. If it is acessable from the outside then I would pull it. If the oil leak is that bad, whats to lose.
12-05-2011 02:55 PM
tman
2000 timberwolf yfb250fw middle drive seal

Looking for some help on how change the front seal on the middle drive. I have a severe oil leak coming from the seal for the front drive shaft. All the drawings I have seen look as if it is pressed in from the inside. This means that I have to dis-assemble the entire drive assembly?

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome