charging system - Yamaha Forum : Your Yamaha Motor Products Community & Resource
Search for the Stars Royal Star, Road Star, V Star, etc.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 12-21-2018, 12:19 PM Thread Starter
Site Supporter
 
Join Date: Dec 2018
Posts: 1
 
charging system

I have a 2001 Royal Star 1300.
Last year I was having charging issues and R/R my rectifier, which solved the then problem. I had to purchase a new battery during my troubleshooting. i'm not able to ride very often, so I always have a battery tender connected. I took the bike for a short ride the other day, about a half hour, city riding...traffic lights and such, and after stopping and turning the bike off for about 15 minutes, it wouldn't start. I was able to call a friend and we trailered the bike home. I put it on the tender and in a day or so, the battery was charged and started right up. When i metered the battery when the bike was running, I'm only getting about 12.5 volts, which I believe should be more than that at idle, I even increased the RPM's to see if the reading went up, and it did not.
what are some troubleshooting tips i can do to see if its my rectifier again....or if it's the generator, or something else?
Thanks
Retiredguy
Retiredguy is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Forum : Your Yamaha Motor Products Community & Resource forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Noyt charging batter, even tho battery is new 1993 yzf750 collywog19 Mechanical / How To 2 03-04-2010 09:26 PM
Battery not charging.... yzf750r collywog19 FZ's, FZR's, & YZF 750 3 02-27-2010 03:56 PM
battery not charging robles364 Mechanical / How To 3 01-26-2009 05:28 AM
Vmax charging frankw32 V-Max & Virago 0 07-07-2008 07:44 AM
battery is not charging, pls. help CT's Finest YZF-R1 13 07-02-2008 09:28 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome