engine light... - Yamaha Forum : Your Yamaha Motor Products Community & Resource
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 08-04-2008, 07:51 PM Thread Starter
Junior Member
 
CT's Finest's Avatar
 
Join Date: May 2008
Location: CT
Posts: 18
 
error codes?? anyone??

so while reading yamaha's repair manual, i learned that our bikes have a self diagnostic machine that gives us error codes right on the odometer. but in the manual is NOT a list of what the codes mean. well, my bike is giving me a code of 17 & 18...does anyone know what those two codes mean? does anyone have a listing of the other codes??
thanx everyone...
CT's Finest is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 08-04-2008, 07:52 PM Thread Starter
Junior Member
 
CT's Finest's Avatar
 
Join Date: May 2008
Location: CT
Posts: 18
 
engine light...

is it normal for the engine light to come on and stay on after changing the exhaust system?? i'm only asking because mine did... anyone with any info???
CT's Finest is offline  
post #3 of 12 (permalink) Old 08-04-2008, 07:57 PM
time in a bottle
 
macattack's Avatar
 
Join Date: Oct 2007
Location: indiana
Posts: 1,349
 
on my 07 R1 it did until I took the servo motor(for the exup valve) apart to remove cables and then reinstalled servo motor. Its like 4oz and some people would rather have the light on than add that servo back.
there is someone on the net that sells a sealed chip that replaces the servo motor and tricks the bike into thinking the exup valve is working properly.

David
macattack is offline  
 
post #4 of 12 (permalink) Old 08-04-2008, 08:12 PM
Administrator
 
R1Lover's Avatar
 
Join Date: Oct 2007
Location: California
Posts: 4,755
 
Yes there are a few ways to get the light off, but leaving the servo on is the easiest.
R1Lover is offline  
post #5 of 12 (permalink) Old 08-04-2008, 08:26 PM
time in a bottle
 
macattack's Avatar
 
Join Date: Oct 2007
Location: indiana
Posts: 1,349
 
exup valve error from removing the servo motor the bike thinks it is locked or out of adjustment

screenshot_01.jpg

David
macattack is offline  
post #6 of 12 (permalink) Old 08-05-2008, 05:18 AM Thread Starter
Junior Member
 
CT's Finest's Avatar
 
Join Date: May 2008
Location: CT
Posts: 18
 
Quote:
Originally Posted by macattack View Post
exup valve error from removing the servo motor the bike thinks it is locked or out of adjustment

Attachment 5051

do you have the complete list of codes???

& this might be a dumb question but i'm new to the guts of a bike & am allowed to ask some of these dumb questions...lol whats exup???
CT's Finest is offline  
post #7 of 12 (permalink) Old 08-05-2008, 05:20 AM Thread Starter
Junior Member
 
CT's Finest's Avatar
 
Join Date: May 2008
Location: CT
Posts: 18
 
Quote:
Originally Posted by R1Lover View Post
Yes there are a few ways to get the light off, but leaving the servo on is the easiest.

so no harm in doing so?? also does this thread tie into my other thread about error codes? i'm getting 17 & 18 for an error code but i'm pretty sure that has to do with the new exhaust & engine light being on...pls. correct me if im wrong..

thanx ya'll everyones been a big help..
CT's Finest is offline  
post #8 of 12 (permalink) Old 08-05-2008, 06:48 AM
time in a bottle
 
macattack's Avatar
 
Join Date: Oct 2007
Location: indiana
Posts: 1,349
 
Quote:
Originally Posted by CT's Finest View Post
do you have the complete list of codes???

& this might be a dumb question but i'm new to the guts of a bike & am allowed to ask some of these dumb questions...lol whats exup???
An exup is the exhaust valve located near the middle of the exhaust . it is a servo controlled valve once you remove it it sends codes . reinstall the servo motor without the cables, and the bike thinks the exup is still there.

David
macattack is offline  
post #9 of 12 (permalink) Old 08-05-2008, 06:54 AM
time in a bottle
 
macattack's Avatar
 
Join Date: Oct 2007
Location: indiana
Posts: 1,349
 
threads merged , because the same issue appears to be listed on two threads. Please let me know if I am mistaken.

David
macattack is offline  
post #10 of 12 (permalink) Old 08-05-2008, 08:39 AM
STRAIGHT ROADS SUCK
 
R1 MASTER's Avatar
 
Join Date: Oct 2007
Location: Illinois
Posts: 2,704
 
Your correct, and good advice also.


Ride safe.

R1 MASTER is offline  
post #11 of 12 (permalink) Old 08-08-2008, 12:29 AM
Senior Member
 
christopherr1's Avatar
 
Join Date: Nov 2007
Posts: 419
 
Quote:
Originally Posted by R1 MASTER View Post
Your correct, and good advice also.


Ride safe.
my bike also read error code 17 oxygen sensor of.. it happens when u get a full exhuast.. ull be ok with the engine light on...
christopherr1 is offline  
post #12 of 12 (permalink) Old 08-08-2008, 04:05 AM
STRAIGHT ROADS SUCK
 
R1 MASTER's Avatar
 
Join Date: Oct 2007
Location: Illinois
Posts: 2,704
 
Removing the 02 sensor will not throw a code on Yamaha's.

If you're getting a code 17 after installing a full exhaust system, it is from the Exup Servo.


Ride safe.

R1 MASTER is offline  
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha Forum : Your Yamaha Motor Products Community & Resource forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
94'YZF750 Oil Light? FED34FIRE General Bike Discussion 1 08-16-2010 02:49 PM
Pictures of smoked tail light/smoked integrated tail light RiderRob YZF-R1 5 03-04-2010 12:38 AM
Oil light 01 r6 r6yamaha YZF-R6, R6S, 600R 0 02-15-2010 08:55 PM
Low gas light fire343 YZF-R1 5 09-13-2009 08:09 AM
07 r6 engine light comes on random OCR6 General Bike Discussion 0 08-09-2009 01:08 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome